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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"
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This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation >Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.

4

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

http://www.ansys.com/Support/


Table of Contents
Table of Contents Contents-1

1 - Introduction 1-1

The Sample Problem 1-1

Results of Analysis 1-2

Overview of the Interface 1-2

2 - Creating the New Project 2-1

Add the New Project 2-1

Insert an HFSS Design 2-2

Add Project Notes 2-2

Select the Solution Type 2-3

Save the Project 2-5

3 - Set Up the Drawing Region 3-1

Enable Legacy View Orientations 3-1

Overview of the Modeler Window 3-3

Coordinate System Settings 3-4

Units Settings 3-4

Grid Settings 3-5

Transparency Setting 3-6

4 - Creating the Model Geometry 4-1

Draw the Polyline1 Object 4-1

Verify the Points of Polyline1 4-6

Duplicate and Mirror Polyline1 4-10

Unite Polyline1 and Polyline1_1 4-12

Modify the Waveguide’s Attributes 4-14

Rename Polyline1 4-14

Assign a Color to the Waveguide 4-14

Assign a Transparency to the Waveguide 4-15

Verify that Lighting Is Enabled and Using Default Attributes 4-16

Getting Started with HFSS: 20 GHzWaveguide Combiner

Contents-1

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: 20 GHzWaveguide Combiner

Sweep the Waveguide 4-17

5 - Setting Up the Problem 5-1

Set Up Boundaries and Excitations 5-1

Boundary Conditions 5-1

Assign Boundaries 5-2

Assign a Finite Conductivity Boundary to the Bottom and Side Faces 5-2

Assign a Perfect E Symmetry Boundary to the Top Face 5-9

Excitation Conditions 5-14

Assign Excitations 5-15

Assign Wave Port 1 5-16

Assign Wave Port 2 5-17

Assign Wave Port 3 5-18

Assign Wave Port 4 5-19

Verify All Boundary and Excitation Assignments 5-20

6 - Set up and Generate a Solution 6-1

Specify Solution Options 6-1

Add a Solution Setup 6-1

Add a Discrete Frequency Sweep 6-4

Validate the Project Setup 6-6

Generating the Solution 6-7

Analyze the Setup You Defined 6-8

View the Solution Data 6-9

View the Profile Data 6-9

View the Convergence Data 6-11

View the Matrix Data 6-12

7 - Analyzing the Solution 7-1

Create an S-Parameters Report of S11, S12, S13, and S14 7-1

Create an S-Parameters Report of S12 and S14 7-3

Scale the Magnitude and Phase for the Ports 7-5

Create a Mag E Field Overlay 7-7

Contents-2

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: 20 GHzWaveguide Combiner

Create a Phase Animation of the Mag E Overlay 7-8

Self-Study Challenge: 7-9

8 - Optionally, Restore Current View Orientations 8-1

Contents-3

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Contents-4

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with HFSS: 20 GHzWaveguide Combiner



1 - Introduction
ThisGetting Started guide describes how to set up and solve a two-way, low-loss waveguide
combiner.

By following the steps in this guide, you will learn how to perform the following tasks in HFSS:

l Draw a geometric model.
l Modify a model’s design parameters.
l Assign variables to a model’s design parameters.
l Specify solution settings for a design.
l Validate a design setup.
l Run an HFSS simulation.
l Create plots and a field overlay of the results (see Results of Analysis).

The Sample Problem
For this problem, the waveguide combiner is a standard WR42 model with a four-port combining
junction. Each waveguide is 420 mils wide and 170 mils high. This type of waveguide combiner
is used to combine the output power of two 20 GHz solid state power amplifiers (SSPA) with a
very compact size and low insertion loss.

The outputs of the SSPAs are fed into Ports 2 and 4 of the waveguide with a 90-degree out-of-
phase separation to steer the output power of the amplifiers to port 1. Port 3 of the waveguide is
the isolated port where the impedance mismatch at the output (port 1) is absorbed.

This problem is also described and analyzed in the following reference:

Arcioni, Paolo, Perregrini, Luca, Bonecchi, Fulvio, “Low-Loss Waveguide Combiners for
Multidevice Power Amplifiers,” The Second International Conference on Electromagnetics in
Aerospace Applications, September 1991.

The geometry for this waveguide combiner problem is shown below:

Getting Started with HFSS: 20 GHzWaveguide Combiner
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Results of Analysis
After setting up the waveguide combiner model and generating a solution, you will:

l Create Modal S-parameter reports (2D x-y plot).
l Create a field overlay cloud plot of the magnitude of E.
l Create an animation of the mag-E cloud plot.

Overview of the Interface
Below is an overview of the major components of the HFSS interface.

Note:

The background color can be changed from View >Modify Attributes > Background
Color.

Introduction 1-2
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Project Manager window Displays details about all open HFSS projects. Each project
has its own project tree, which ultimately includes a geometric
model and its boundaries and excitations, material assign-
ments, analysis setups, and analysis results.

Message Manager win-
dow

Displays error, informational, and warning messages for the
active project.

Progress window Displays solution progress information.

Introduction 1-3
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Properties window Displays the attributes of a selected object in the active
model, such as the object’s name, material assignment, ori-
entation, color, and transparency.

Also displays information about a selected command that has
been carried out. For example, if a circle was drawn, its com-
mand information would include the command’s name, the
type of coordinate system in which it was drawn, the circle’s
center position coordinates, the axis about which the circle
was drawn, and the size of its radius.

Modeler window Displays the drawing area of the active model, along with the
History Tree.

History Tree Displays all operations and commands carried out on the act-
ive model, such as information about the model’s objects and
all actions associated with each object, and coordinate sys-
tem information.

Menu bar Provides various menus that enable you to perform all of the
HFSS tasks, such as managing project files, customizing the
desktop components, drawing objects, and setting and modi-
fying all project parameters.

Toolbars Provides buttons that act as shortcuts for executing various
commands.

Status bar Shows current actions and provides instructions.

Also, depending on the command being carried out, the
status bar can display the X, Y, and Z coordinate boxes, the
Absolute/Relative pull-down list to enter a point’s absolute
or relative coordinates, a pull-down list to specify a point in
Cartesian, Cylindrical, or Spherical Coordinates, and the act-
ive model’s unit setting.

Component Libraries Component libraries contain ready-to-insert 3D Components,
which are stored in the PersonalLib and in the SysLib
folders. Component Libraries allow easy access to the 3D
Components.
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2 - Creating the New Project
Your goals in this chapter are as follows:

l Create a new project.
l Add an HFSS design to the project.
l Optionally add project notes.
l Select the Solution Type
l Save the project with a user-specified name.

This chapter describes how to create a project in which to save all the data associated with the
problem. By default, when you launch the Ansys Electronics Desktop a new project named Pro-
jectn is automatically created into which you can insert a new design HFSS design type.

You can also create a new project and insert a design manually.

Time It should take you approximately 10 minutes to work through this
chapter.

Add the New Project
1. Launch the Electronics Desktop application, if it is not already running.
2. If you have just started Electronics Desktop, a new project has already been created for

you automatically. You can skip this step. However, if you previously opened Electronics
Desktop and then closed the project you had been working on, do one of the following to
create a new project:

l From the menu bar, click File > New.

l

From the Desktop tab of the ribbon, click New.

A new project is listed at the top of the Project Manager window. It is named Projectn by
default, where n is a serial number incremented from the highest existing Projectn file

Creating the New Project 2-1
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already in the default project folder. Project definitions, such as boundaries and material
assignments, are stored under the project name shown in the Project Manager.

Insert an HFSS Design
The next step for this waveguide combiner problem is to insert an HFSS design into the new pro-
ject. On adding an HFSS design type, a design named HFSSDesignn with the solution type as
[Driven Modal] appears for the current project.

3. Select the project name (Projectn) at the top of the Project Manager window.
4. To manually insert an HFSS design into the project, do one of the following:

l Using the menu bar, click Project > Insert HFSS Design.
l Right-click the project name in the Project Manager window, and then select
Insert > Insert HFSS Design from the shortcut menu.

l

In the Desktop tab of the ribbon, click Insert HFSS Design.
l In the Desktop tab of the ribbon, choose HFSS from the Insert HFSS Design
drop-down menu.

An HFSS Design icon and heading are added to the Project Mnager, as shown below:

Add Project Notes
You can enter notes about your project, such as its creation date and a description of the device
being modeled. These notes are useful for keeping a running log of the project details and for

Creating the New Project 2-2
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future reference.

To add notes to the project:

1. In the Project Manager, right-click the HFSS design type heading (default =
HFSSDesignn) and select Edit Notes from the short-cut menu.

The Design Notes window appears.

2. Click inside the window and type your notes, such as a description of the model, assumed
conditions, and the software version in which it is being created.

3. ClickOK to save the notes with the current project.

Note:

To edit existing project notes, double-click Notes in the Project Manager. The Design
Notes window appears, and you can edit its content as needed.

Select the Solution Type
Before you draw the geometry, specify a solution type as follows:

1. Access the Solution Type dialog box using one of the following two methods:
l Using the menu bar, click HFSS > Solution Type.
l In the Project Manager, right-click HFSSDesignn and choose Solution Type from
the shortcut menu.

The Solution Type dialog box appears.

2. UnderOptions, chooseModal.

The Solution Type should be HFSS, and also, Network Analysis should be selected
underOptions:

Creating the New Project 2-3
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Some of the possible solution types and options are described below:

Modal For HFSS and HFSS or HFSS with Hybrid and Array solutions only.
This option calculates the mode-based S-parameters of passive, high-
frequency structures such as microstrips, waveguides, and trans-
mission lines, which are “driven” by a source.

Terminal For HFSS and HFSS or HFSS with Hybrid and Array solutions only.
This option calculates the terminal-based S-parameters of passive,
high-frequency structures with multi-conductor transmission line ports,
which are “driven” by a source.

The solution produces terminal-based results related to voltages and
currents.

Eigenmode Calculates the eigenmodes, or resonances, of a structure. The Eigen-
mode solver finds the resonant frequencies of the structure and the
fields at those resonant frequencies.

Creating the New Project 2-4
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3. ClickOK to apply theModal solution type to your design.

Save the Project
Next, save and name the new project.

It is important to save your project frequently to prevent loss of your work if a problem occurs.

Note:

By default, Ansys Electronics Desktop autosaves your projects every ten edits. Auto-
save settings are found in theGeneral > Desktop Configuration section of the Gen-
eral Options. You can change the autosave interval or disable the feature.

To save the new project:

1. From the menu bar, click File > Save As.

The Save As dialog box appears.

2. Use the file browser to find the directory where you want to save the file.
3. Type the namewg_combiner in the File name text box.
4. In the Save as type list, accept Ansys Electronics Desktop Project File (*.aedt) as the

correct file type.

When you create an HFSS project, it is given an .aedt file extension by default and placed
in the project directory. Any files and subfolders related to that project are stored in the
same directory.

5. Click Save.

The project is saved to the specified location.

Note:

For more information on any topic in HFSS, such as coordinate systems and grids or
Modeler commands or windows, you can view the context-sensitive help:

l Click the Help button in a pop-up window.
l Press F1. This opens the Help window. If you have a dialog open, or if the cursor
is pointing at a menu command, your browser opens to a page that describes the
dialog box or command (context-sensitive help).

l Use the commands from the Helpmenu.

At this point you are ready to set up the drawing region in preparation for drawing the waveguide
combiner.

Creating the New Project 2-5
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3 - Set Up the Drawing Region
The next step is to set up the drawing region.

In this chapter, you will:

l Enable Legacy View Orientations
l Look at an overview of theModeler window
l Learn about settings for the following four items:

l Coordinate System
l Units
l Grid
l Transparency

For this waveguide combiner problem, use the default coordinate system, specify the units, and
define the grid settings.

Enable Legacy View Orientations
This getting started guide was created based on standard view orientations that were in effect
for version 2023 R2 and earlier of the Ansys Electronics Desktop application. For consistency
between your experience and the views and instructions contained in this guide, select the
Enable Legacy View Orientation option in the 3D UI Options dialog box, as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Select Enable Legacy View Orientation:

Set Up the Drawing Region 3-1
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3. ClickOK.

Changing the view orientation option does not change the model viewpoint that was in
effect at the time.

4. On the Draw ribbon tab, click Orient to change to the Trimetric view, which is the
default legacy view orientation.

You do not have to select Trimetric from theOrient drop-down menu. The default view
appears when you clickOrient.

Although this option can only be accessed once a design is added to a project, it is a global
option. Your choice is retained for all future program sessions, projects, and design types that
use the 3D Modeler or that produce 3D plots of results.

At the end of this guide, you will be prompted to clear the Enable Legacy View Orientation
option, if you prefer to use the view orientation scheme implemented for 2024 R1 and newer ver-
sions going forward.

For a comparison of the legacy and current view orientations, search for "View Options: 3D UI
Options" in the HFSS help. Additionally, views associated with Alt + double-click zones have

Set Up the Drawing Region 3-2
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been redefined. The current orientations are shown in the help topic, "Changing the Model View
with Alt+Double-Click Areas."

Overview of the Modeler Window
The area containing the model is called the drawing region. Models are drawn in theModeler win-
dow, which appears in the desktop after you insert a design into the project.

As shown below, theModeler window consists of a Grid, coordinate axes, a scale indicator
(Ruler), a View Orientation Gadget, and a History Tree. The view orientation gadget provides a
convenient alternative for manipulating the model viewpoint, as opposed to using the menubar,
ribbon commands, or other mouse actions. The grid is an aid to help visualize the location and
size of objects. For more information about the grid, see “Grid Settings”.

The History Tree displays all operations and commands carried out on the active model. See
“HistoryTree” for more information.

Set Up the Drawing Region 3-3
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Coordinate System Settings
For this waveguide combiner problem, use the fixed, default global coordinate system (CS) as
the working CS. This is the current CS with which objects being drawn are associated.

HFSS has three types of coordinate systems that let you easily orient new objects: a global
coordinate system, a relative coordinate system, and a face coordinate system. Each of these
coordinate systems has an x-axis that lies at a right angle to a y-axis, and a z-axis that is normal
to the xy plane. The origin (0,0,0) of every CS is located at the intersection of the x-, y-, and z-
axes.

Global CS The fixed, default CS for each new project. It cannot be edited or deleted.

Relative CS A user-defined CS. Its origin and orientation can be set relative to the
global CS, relative to another relative CS, or relative to a geometric fea-
ture. Relative CS enables you to easily draw objects that are located rel-
ative to other objects.

Face CS A user-defined CS. Its origin is specified on a planar object face. Face
CS enables you to easily draw objects that are located relative to an
object’s face.

Units Settings
Specify the drawing units for your model. For this waveguide combiner problem, set the drawing
units to mils (also known as milli-inches; 1 mil = 0.001 inch).

To set the drawing units:

1. Access the Set Model Units and Max Extent dialog box using one of the following two
methods:

l Using the menu bar, clickModeler > Units.
l From the Draw tab of the ribbon, click Units.

2. Selectmil from the Select units drop-down menu and ensure Rescale to new units is
cleared. Also, leave the Advanced option cleared, keeping the default model extents of
+/-10000 length units.

Set Up the Drawing Region 3-4
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Note:

l When Rescale to new units is not selected, the dimensions of any exist-
ing geometry are updated to keep the size and location of the objects
unchanged. For example, a 1 inch cube would become an equivalent 25.4
mm cube when changing units from inch to mm.

l When Rescale to new units is selected, the numerical values of any exist-
ing dimensions remain unchanged, but the units are redefined. This pro-
cess changes the physical size and location of the previously drawn
objects. For example, a 1 inch cube with its lower left corner placed 1 inch
in the +X direction from the origin would become a 1 mm cube placed 1
mm from the origin. Use this option to correct objects drawn using the cor-
rect numerical values but the wrong units setting.

l In either case, the grid spacing is adjusted to reflect the new units.

3. ClickOK to accept mils (thousandths of an inch) as the length unit for drawing this model.

Grid Settings
The grid displayed in theModeler window is a drawing aid that helps to visualize the location and
size of objects. In addition, the cursor can snap to grid points when drawing objects graphically,
depending on the settings under 3D Modeler > Snap in the General Options. The points on the
grid are divided by their local x-, y-, and z-coordinates, and grid spacing is set according to the
current project’s drawing units.

To edit the grid’s properties, clickGrid Settings on the Viewmenu. You can control the grid type
(Cartesian or polar), style (dots or lines), density, spacing, or visibility.

Set Up the Drawing Region 3-5
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For this waveguide combiner project, it is not necessary to edit any of the grid’s default prop-
erties.

Transparency Setting
Set the default transparency for objects to 0.4.

To set the default transparency for new objects:

1. Access theOptions dialog box using one of the following two methods:
l From the menu bar, click Tools >Options >General Options.

l In the Desktop tab of the ribbon, click General Options.
2. In the options tree, expand the 3D Modeler branch and the Display sub-branch. Then,

click Rendering.
3. Change the Default transparency to 0.4.

Set Up the Drawing Region 3-6
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4. ClickOK.

Set Up the Drawing Region 3-7
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4 - Creating the Model Geometry
This chapter shows you how to create the geometry for the waveguide combiner problem
described earlier. Your goals are as follows:

l Drawing the objects that make up the waveguide combiner.
l Assigning color and transparency to the objects.
l Assigning materials to the objects.

The geometry for this model consists of a single standard WR42 waveguide combiner object
with a four-port, low-loss combining junction. Each waveguide is 420 mils wide and 170 mils
high.

The waveguide combiner starts out as a 2D sheet object (a geometric object containing surface
area but no volume). You draw the sheet object on the XY plane as a series of polylines enclos-
ing an area. Since this model is symmetrical about the xz plane, just draw the left-half of the
structure's outline. Then, complete the outline of the sheet object by duplicating and mirroring
the left side to create the right side. Finally, merge (that is, Union) the two sides together.

Create the 3D waveguide combiner by sweeping the 2D sheet object in the Z direction. To
reduce the size of this model, only sweep the outline half of its actual height (170 mils / 2 = 85
mils). Assign a perfect E symmetry boundary to the top face of the waveguide combiner to rep-
resent the other (unmodeled) half of the device. This technique reduces the mesh volume to half
that of the full model, thereby shortening the solution time.

For a detailed description about this waveguide combiner, see “The Sample Problem”.

You are all set to draw the geometry.

Time It should take you approximately 30 minutes to work through this chapter.

Draw the Polyline1 Object
The first object to be drawn is the left half of the waveguide combiner. Do this by drawing a
closed polyline object consisting of 24 unique points and therefore 24 line segments. While you
will specify 25 points, the first and last are identical. That is, the path ends on its starting point.
This procedure results in a 2D sheet object with a default name of Polyline1.

To draw Polyline1, enter the point coordinates in sequence for each vertex of the 24 polyline seg-
ments while creating them.
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1. From the menu bar, click Draw > Line or, on the Draw ribbon tab, click Draw line.

The status bar now prompts you to enter the first point of the polyline.

2. Press Tab to move to the X text box along the bottom of the program window. Then, spe-
cify the first point of the line by typing the following X, Y, and Z values, pressing Tab to
jump to the next coordinate text box. (You can also press Shift+Tab to jump to the pre-
vious text box.):

Point X Coordinate Y Coordinate Z Coordinate

1 0 0 0

Important:

l Keep your hand off of the mouse when tabbing into the coordinate text
boxes and be very careful not to bump the mouse while typing the coordin-
ates. Any mouse movement will cause the numerical values to revert to
the graphical location of the cursor and can cause the input mode to
change from Absolute to Relative.

l Ensure that the drop-down menu to the right of the coordinate text boxes is
set to Absolute for the first point and for all subsequent points:

If you move the mouse after typing the first set of coordinates, the input
mode will automatically switch to Relative for subsequent points. After
resetting it to Absolute, the setting will remain unchanged for the duration
of the Line command, despite further mouse movements.

3. Press Enter to accept the first point.
4. Continue with this same method and carefully enter the 24 points that remain, as listed in

the table below.

To keep track of the points you are entering, closely observe the Position1 and Position2
values in theMeasure Data window. After typing the coordinates for the next point (but not
pressing Enter yet), Position1 will still report the previous point that you defined, and Pos-
ition2 will show the coordinates of the point currently being defined:
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As soon as you press Enter, both Position1 and Position2 will report the coordinates of
the point just defined:

Note:

If you accidentally enter an incorrect set of coordinates, you can delete the last
point you entered by right-clicking in theModeler window and then clicking Undo
Previous Segment on the shortcut menu.
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Point X Coordinate Y Coordinate Z Coordinate

2 0 -53 0

3 -147 -53 0

4 -474 -367 0

5 -474 -710 0

6 -944 -710 0

7 -944 -1130 0

8 -369 -1130 0

9 -27 -792 0

10 -27 -467 0

11 83 -467 0

12 146 -433 0

13 255 -433 0

14 337 -411 0

15 427 -411 0

16 506 -523 0

17 682 -523 0

18 915 -683 0

19 1562 -683 0

20 1562 -263 0

21 1073 -263 0

22 858 -53 0

23 612 -53 0

24 612 0 0

25 0 0 0

5. Right-click in theModeler window, and click Close Polyline on the shortcut menu.
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A sheet object appears in the History tree, the object is shaded (selected) in the drawing
region, and the Properties dialog box appears (if configured to do so when new primitives
are created).

Note:

Objects are automatically selected immediately after being drawn so that you can
instantly view the default attributes and optionally modify them.

6. The object is named Polyline1 by default, as displayed in the Attributes tab of the docked
Properties window and the Properties dialog box (if it appears).

7. ClickOK to dismiss the Properties dialog box if it appears.
8. Press Ctrl+D to fit the object in the drawing region.

The completed left-half of the waveguide combiner should appear in theModeler window,
as shown below:
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If the appearance of the model is not as shown, proceed to the next step, where you will
verify the coordinates of each line segment.

Verify the Points of Polyline1
Before you duplicate and mirror the object Polyline1 to create the right-side of the waveguide
combiner, it is important that you make sure all the points you entered are correct. You will not
obtain the expected simulation results if the geometry is not exactly as described in this exercise.

The image below shows all the point locations used to define the segments for the object
Polyline1:
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To verify the points:

1. In the History Tree, click the plus (+) symbol to the left of Sheets to expand the tree struc-
ture to see Unassigned. Expand the structure under Unassigned to see Polyline1.
Expand the structure under Polyline1 to see Create Polyline. Expand the structure
under Polyline1 to see 24 CreateLine commands under CreatePolyline.
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2. Click the first CreateLine object in the list to view the coordinate values that you entered
for point 1 (0, 0, 0) and point 2 (0, -53, 0).

These values are displayed in the docked Properties window, as shown below:

3. Verify that the values for these points are correct.
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Point X Coordinate Y Coordinate Z Coordinate

1 0 0 0

2 0 -53 0

3 -147 -53 0

4 -474 -367 0

5 -474 -710 0

6 -944 -710 0

7 -944 -1130 0

8 -369 -1130 0

9 -27 -792 0

10 -27 -467 0

11 83 -467 0

12 146 -433 0

13 255 -433 0

14 337 -411 0

15 427 -411 0

16 506 -523 0

17 682 -523 0

18 915 -683 0

19 1562 -683 0

20 1562 -263 0

21 1073 -263 0

22 858 -53 0

23 612 -53 0

24 612 0 0

25 0 0 0

4. To edit an incorrect point value:
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a. In the History Tree, select the CreateLine object you want to edit.
b. In the Value column of the docked Properties window, enter the correct x, y, and z

coordinates (separated by commas).
The value entered for Point2 automatically applies to Point1 for the next segment.
Therefore, you need only edit Point2 for each of the subsequent CreateLine seg-
ments.

c. Press Enter to apply the new values to the model.

As you enter the values, the display of each segment updates. You may need to
click Fit All on the Draw ribbon tab to resize the object view within theModeler
window.

Note:

l If you accidentally omitted a point (for example, if one segment starts with
the point-8 coordinates and ends with the point-10 coordinates):

a. In the History Tree, right-click the segment that preceeds the invalid
one and choose Insert Segment After > Straight from the shortcut
menu.

b. Specify the coordinates of the missing point in the coordinate entry
text boxes and press Enter.

l If you accidentally specified the same point twice, there will be a zero-
length line segment (the start point and end point coordinates will be
identical).

Right-click the zero-length line segment in the History Tree, and choose
either Delete Start Point or Delete End Point.

l Finally, if you accidentally specified an extraneous point (for example, an
intermediate point between point-12 and point-13):

In the History Tree, right-click the line segment that ends at the extraneous
point and choose Delete End Point.

5. Continue with this same method to verify the values for all remaining points, correct any
errors, and ensure that the appearance of the model is as expected.

Duplicate and Mirror Polyline1
Since the waveguide combiner is symmetric about the xz plane you can duplicate and mirror the
object Polyline1 and create the right-half of the waveguide combiner. This results in a 2D sheet
object with a default name of Polyline1_1.

To duplicate the object Polyline1:
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1. Select the object Polyline1 by either clicking it in theModeler window or selecting it in the
History Tree.

2. You can initiate the duplicate and mirror command using either of the following two meth-
ods:

l Using the menu bar, click Edit > Duplicate >Mirror.
l In the Draw ribbon tab, click Thru Mirror (Mirror Duplicate).

3. Press F3 to use the coordinate-text-box method of defining the mirror plane (rather than
filling in the DuplicateMirror dialog box).

4. Press Tab to move to the X text box at the bottom of the program window and then enter 0
Tab 0 Tab 0 to specify the origin (X=0, Y=0, Z=0) as a point on the mirror plane.

5. Press Enter.

This point and the next point you specify define a line perpendicular to the mirror plane,
fully locating and orienting the plane.

6. Press Tab to move to the dY text box and enter 1 to specify the normal point. (Ensure that
the X and Z coordinates are both 0.)

The normal line defined by this point lies along the Y axis.

7. Press Enter. The object is duplicated and mirrored, and the Properties dialog box
appears, if configured to do so.

8. ClickOK to dismiss the Properties dialog box, if it appears.

The object Polyline1_1, a duplicate of object Polyline1, appears on the opposite side of
the mirror plane you specified.

9. On the Draw ribbon tab, click Fit All.

The model should now look like the following image:
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Unite Polyline1 and Polyline1_1
After successfully creating both halves of the waveguide combiner, unite them to make a single
waveguide combiner object.

To unite both halves of the waveguide combiner:

1. Select Polyline1.
2. While holding down the Ctrl key, also select Polyline1_1.

Both objects (Polyline1 and Polyline1_1) are highlighted in the History Tree, and the
status bar indicates that the number of objects selected is two.

Creating the Model 4-12

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: 20 GHzWaveguide Combiner

Note:

By default, the objects being joined to the first object selected are not preserved
for later use. However, they do become part of the first object selected.

For this waveguide combiner problem, you do not need to preserve any objects
for later use. However, if you wanted to keep a copy of the objects being joined to
the first object selected, you could use one of the following methods:

l Copy the objects, perform the Boolean Unite operation, and then paste the
original objects back into the design after uniting them.

l From the menu bar, click Tools >Options >General Option, go to 3D
Modeler >Operation, and then select the Clone tool objects before
uniting option. This option instructs the 3D Modeler to always keep a copy
of the original objects being joined. Finally, perform the Boolean Unite oper-
ation.

3. ClickModeler > Boolean > Unite.

The new object that is created inherits its properties (name, color, boundary, and material
assignment) from the first object selected (Polyline1).

The resulting united object appears in theModeler window, as shown below:
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Modify the Waveguide’s Attributes
The next step in creating the waveguide is to modify its default attributes that are displayed in the
docked Properties window. You will rename the object, assign a color, adjust the transparency
level, and verify the material assignment. You will also verify the global lighting attributes.

Rename Polyline1
Change the default name of the united object to specify that it is a waveguide combiner. To
modify the name:

1. Reselect Polyline1 if it is not already selected.
2. Under the Attribute tab of the docked Properties window, click Polyline1 in the Name

row.
3. Typewaveguide to rename the object, and press Enter to accept the new name.

Assign a Color to the Waveguide
With the waveguide still selected and the Attribute tab of the Properties window still displayed:

4. Click the currently displayed color bar in the Value column of the Color row. The Color
palette appears.
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5. Select the basic color blue (RGB settings 0, 0, 255), which is the swatch in column 5, row
4 of the Color palette.

6. ClickOK to assign the color to the objectwaveguide.

Note:

While the waveguide is selected, it retains the selection color. To see the
assigned color, deselect the waveguide by clicking a location in the drawing win-
dow outside of the waveguide.

Assign a Transparency to the Waveguide
To assign a transparency level to the waveguide:

7. Reselect the objectwaveguide, if it is not already selected.
8. Under the Attribute tab of the docked Properties window, click the default value 0.4 in the

Values column of the Transparency row.

The Set Transparency window appears.

9. Move the slider to the right to increase the transparency to 0.7, or type this value into the
text box.

10. ClickOK to accept the new transparency value.
11. In theModeler window, click outside thewaveguide object to deselect it for viewing the
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resulting model appearance.

Verify that Lighting Is Enabled and Using Default Attributes
It is not necessary to adjust the global lighting parameters for this waveguide combiner problem.
However, if you want, you can change the default ambient and distant light source properties at
this time.

To verify that default lighting attributes are enabled:

12. Using the menu bar, click View >Modify Attributes > Lighting.

The Lighting Properties dialog box appears.

13. Verify that the Do not use lighting option is cleared (to enable lighting effects).
14. Click Reset from default to restore default settings.

Note:

Optionally, if you have customized lighting settings that you wish to retain, click
Save as default to make your settings the default configuration.

15. ClickOK to accept the settings and close the Lighting Properties dialog box.
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Sweep the Waveguide
Next, you must sweep the 2D objectwaveguide along a vector to create a 3D solid object as the
final waveguide combiner model.

To sweep the waveguide along a vector:

1. Select the objectwaveguide.
2. Execute the Sweep command using one of the following three methods:

l From the menu bar, click Draw > Sweep > Along Vector.
l In the Draw ribbon tab, click Sweep along vector.
l Right-click in theModeler window and choose Edit > Sweep > Along Vector from
the shortcut menu.

3. Specify the vector along which you want to sweep the object:
a. Enter (0, 0, 0) in the X, Y, and Z coordinate text boxes to specify the start point and

press Enter.
b. Tab into the dZ text box (if the cursor is not already there), type 85 to specify the end

point, and press Enter.

The Sweep along vector dialog box appears.

4. Enter 0 in the Draft angle text box.

This is the angle to which the profile is expanded (positive angles) or contracted (negative
angles) as it is swept.

5. You can keep whatever the current Draft type setting is, since this setting will only matter
when a non-zero draft angle is specified or the object is swept along a nonlinear path.

For more information, see Draft Type Options.

6. ClickOK to complete the sweep.
7. ClickOK to dismiss the Properties dialog box (if it appears).
8. Clear the selection.

Your completed 3D objectwaveguide should resemble the one shown below:
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9. Click File > Save, or click the Save icon ( ), available on any ribbon tab, to save the
geometry.

Now you are ready to assign all boundaries and excitations to the waveguide combiner.
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5 - Setting Up the Problem
Now that you have created the geometry and assigned all materials for the waveguide combiner
problem, you are ready to define its excitations and boundaries.

Your goals for this chapter are to:

l Define boundary conditions, in this case finite conductivity boundaries.
l Define the wave ports through which the signals enter and leave the waveguide combiner.
l Verify you correctly assigned the boundaries and excitations to the model.

Set Up Boundaries and Excitations
Now that you have created the waveguide combiner model and defined its properties, you must
define the boundary and excitation conditions. These conditions specify the excitation signals
entering the structure, the behavior of electric and magnetic fields at various surfaces in the
model, and any special surface characteristics.

You are ready to set up the problem.

Time It should take you approximately 15 minutes to work through this
chapter.

Boundary Conditions
Boundaries specify the behavior of magnetic and electric fields at various surfaces. They can
also be used to identify special surfaces—such as resistors— whose characteristics differ from
the default.

The following two types of boundary conditions will be used for this waveguide combiner prob-
lem:

Finite con-
ductivity

This type of boundary represents an imperfect conductor. HFSS does not
compute the field inside these objects; the finite conductivity boundary
approximates the behavior of the field at the surfaces of the objects. Any
skin-effect losses will be properly taken into account.

For this waveguide combiner problem, a finite conductivity boundary is
assigned to the bottom face and the side faces of the model (excluding the
four ports).
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Symmetry In structures that have an electromagnetic plane of symmetry, such as this
waveguide combiner model, the problem can be simplified by modeling only
one-half of the model and identifying the exposed surface as a perfect H or
perfect E boundary.

For this waveguide combiner problem, a perfect E symmetry boundary is
assigned to the top face of the model.

Assign Boundaries
First, assign all boundary conditions to the model. These assignments include two finite con-
ductivity boundaries and one perfect E symmetry boundary. For more about the different types
of boundaries available in HFSS, see “Boundary Conditions”.

Assign a Finite Conductivity Boundary to the Bottom and Side Faces
Assign a finite conductivity boundary to all the waveguide combiner’s side faces, excluding the
four port faces.

As discussed in “Boundary Conditions”, finite conductivity boundaries represent imperfect con-
ductors. At such boundaries, the following condition holds:

where

l Etan is the component of the E-field that is tangential to the surface.
l is the unit normal to the surface.
l Htan is the component of the H-field that is tangential to the surface.
l Zs is the surface impedance of the boundary, , where:

o ẟ is the skin depth, , of the conductor being modeled.
o ω is the angular frequency of the excitation wave.
o σ is the conductivity of the conductor.
o μ is the permeability of the conductor.

The fact that the E-field has a tangential component at the surface of imperfect conductors sim-
ulates the case in which the surface is lossy.

The surfaces of any objects defined to be non-perfect conductors are automatically set to finite
conductivity boundaries. HFSS does not attempt to compute the field inside these objects; the
finite conductivity boundary approximates the behavior of the field at the surfaces of the objects.
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The finite conductivity boundary condition is valid only if the conductor being modeled is a good
conductor, and if the conductor’s thickness is much larger than the skin depth in the given fre-
quency range.

To assign a finite conductivity boundary to the side faces of the waveguide combiner:

1. Right-click in theModeler window, then choose Selection Mode > Faces from the short-
cut menu.

In this mode you can select or deselect an object’s faces instead of the entire object.
When the mouse hovers over a face in theModeler window, that face is outlined, which
indicates that it will be selected when you click.

2. Select all the side faces of the waveguide object except for the four port faces. Addi-
tionally, select the bottom face. Exclude the top face. Hold down the Ctrl key when click-
ing to select multiple faces.

Note:
o To minimize or eliminate the necessity of changing the model viewpoint,
you can select a face that's behind another face. Click on the face you
want to select (even though another face is in front of it). The face in the
foreground is initially selected. Then, press B on the keyboard (or right-
click and choose Next Behind from the shortcut menu) to select the next
face behind the one just selected.

o You can also be creative with techniques for selecting multiple items in
one operation. For example, click and drag to draw selection rectangles,
noting that the direction you drag affects the selection behavior:

n When dragging left-to-right, only items that are fully enclosed within
the rectangle are selected.

n When dragging right-to-left, all items that are fully enclosed withing
the rectangle and all items that the rectangle crosses through are
selected.

The selected faces should look like the figure below. Note that the two port faces in the
foreground (+X end) appear to be selected in the first image, but they are not. Due to the
model viewpoint, the bottom highlighting is seen through these two faces.
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If you rotate the view orientation, you will see that these two faces are not selected, but
from that viewpoint, the other two ports will then look like they're selected.
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3. On the HFSSmenu, click Boundaries > Assign > Finite Conductivity or right-click in
theModeler window and choose Assign Boundary > Finite Conductivity.

The Finite Conductivity Boundary window appears.
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4. Set the material to aluminum. To do this:
a. Select the Use Material check box.
b. Click the material button (where the default vacuum is displayed).

The Select Definition dialog box appears. By default, this material browser lists all
materials in the systemMaterials library, as well as the local library for the current
project, which is a subset of the system library.
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c. Select aluminum from the list of materials and clickOK.

The Finite Conductivity Boundary window reappears.

The conductivity and permeability values for aluminum are now assigned to the
finite conductivity boundary.

5. Clear Infinite Ground Plane if it is selected.

If selected, this option simulates the effects of an infinite ground plane, and it only affects
the calculation of near- and far-field radiation during post processing. The 3D Post Pro-
cessor models the boundary as a finite portion of an infinite, perfectly conducting plane.

6. ClickOK to accept the default name FiniteCond1 and apply the boundary.
7. The resulting finite conductivity boundary is applied to the side faces of the object wave-

guide and now appears as a subentry of Boundaries in the Project Manager. Select Fin-
iteCond1 to highlight the assigned boundary if it is not already displayed. Your model
should look like the following image:
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By default, the geometry, name, and vectors for the boundary appear in theModeler win-
dow. For this waveguide combiner problem, it is not necessary to edit any of the bound-
ary’s default visualization settings.
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Note:

To edit a boundary’s visualization settings:

1. Click HFSS > Boundaries > Visualization if you want to show or hide
boundaries.

2. Clear the View Geometry, View Name, or View Vector selection of
boundaries that you want to hide from view. Select the options you want to
show in theModeler window.

3. Click Close.

Assign a Perfect E Symmetry Boundary to the Top Face
HFSS has a boundary condition specifically for symmetry planes. Instead of defining a perfect E
or perfect H boundary, you define a perfect E or perfect H symmetry plane.

When you are defining a symmetry plane, you must decide which type of symmetry boundary
should be used, a perfect E or a perfect H. In general, use the following guidelines to decide
which type of symmetry plane to use:

l If the symmetry is such that the E-field is normal to the symmetry plane, use a perfect E
symmetry plane.

l If the symmetry is such that the E-field is tangential to the symmetry plane, use a perfect H
symmetry plane.

The simple two-port rectangular waveguide shown below illustrates the differences between the
two types of symmetry planes. The E-field of the dominant mode signal (TE10) is shown. The
waveguide has two planes of symmetry, one vertically through the center and one horizontally.

l The horizontal plane of symmetry is a perfect E surface. The E-field is normal and the H-
field is tangential to that surface.

l The vertical plane of symmetry is a perfect H surface. The E-field is tangential and H-field
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is normal to that surface.

Since the E-field is symmetric to the height of the waveguide combiner model, the height of the
waveguide has been split in half in order to place a perfect E symmetry boundary on the top
face.

Next, you will assign a perfect E symmetry boundary to the top face of the waveguide combiner
(the symmetry plane for the model).

To assign a symmetry boundary to the top face of waveguide:

1. If it is still selected, deselect the finite conductivity boundary you just assigned.
2. In Select Facesmode, select the top face of the objectwaveguide.
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3. On the HFSSmenu, click Boundaries > Assign > Symmetry.

The Symmetry Boundary dialog box appears.
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4. Select Perfect E as the symmetry type.
5. Because you defined a symmetry plane (allowing the model of a structure to be cut in

half), the impedance computations must be adjusted by specifying an impedance mul-
tiplier.

In cases such as this waveguide combiner problem, where a perfect E plane of symmetry
splits a structure in two, only one-half of the voltage differential and one-half of the power
flow can be computed by the system.

Therefore, since the impedance, Zpv, is given by , the computed value is
one-half the desired value. An impedance multiplier of 2 must be specified in such cases.

Do the following to edit the impedance multiplier:

a. Click Edit Port Impedance Multiplier.

The Edit Port Impedance Multiplier dialog box appears.
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b. Enter the value 2 in the Impedance Multiplier box, and then clickOK.

Note:

You can also set the impedance multiplier from the HFSSmenu by clicking
Excitations > Edit Port Impedance Multiplier.

6. ClickOK to accept the default name Sym1 and apply the boundary.

The resulting perfect E symmetry boundary condition is assigned to the top face of the
objectwaveguide, as shown below. Select Sym1 in the Project Manager if the boundary
is not already displayed.:
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Excitation Conditions
Wave ports define surfaces exposed to non-existent materials (generally the background or
materials defined to be perfect conductors) through which excitation signals enter and leave the
structure.

Wave ports represent places in the geometry through which excitation signals enter and leave
the structure. They are used when modeling strip lines and other waveguide structures, such as
this waveguide combiner problem. Wave ports are typically placed on the perfect E interface
between the 3D object and the background to provide a window that couples the model device to
the external world.

For this waveguide combiner problem, a wave port is assigned to each end-face of the model’s
four waveguide sections.

Setting Up the Problem 5-14

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: 20 GHzWaveguide Combiner

Assign Excitations
Now you will assign all excitations to the waveguide combiner model. These excitations include
wave ports assigned to each end face of the model’s four waveguide sections, as shown below.
The model orientation in this image is Trimetric, and the ports have been selected for clarity:

Wave ports represent places in the geometry through which excitation signals enter and leave
the structure. HFSS assumes that each wave port you define is connected to a semi-infinitely
long waveguide that has the same cross-section and material properties as the port.

When solving for the S-parameters, HFSS assumes that the structure is excited by the natural
field patterns (modes) associated with these cross-sections. The 2D field solutions generated for
each wave port serve as boundary conditions at those ports for the 3D problem. The final field
solution computed must match the 2D field pattern at each port.

For this waveguide combiner model, you will assign four wave ports to the locations shown in the
above image.

The functions of each wave port in this waveguide combiner model are as follows:
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Port 1 One of two output ports, along with Port 3.

In a later procedure, each of the opposite two ports (2 and 4) will
receive the output from a solid-state power amplifier (SSPA). The out-
put at Port 1 depends on the phase angle between the inputs applied
to Ports 2 and 4. With the Port 4 input 90-degrees out-of-phase with
Port 2, we expect all of the power to flow out of Port 1, fully combining
the SSPA outputs.

Port 2 One of two input ports, along with Port 4, to which the output of an
SSPA will be fed.

Port 3 One of two output ports, along with Port 1.

The output at Port 3 depends on the phase angle between the inputs
applied to Ports 2 and 4. With the Port 4 input 90-degrees out-of-
phase with Port 2, we expect Port 3 to be isolated with essentially
zero output.

Port 4 One of two input ports, along with Port 2, to which the output of an
SSPA will be fed.

Port 4 will receive the output of the SSPA but 90-degree out-of-
phase relative to Port 2.

Assign Wave Port 1
To assign wave port 1:

1. Deselect the perfect E boundary you just assigned, if it is still selected.
2. In Select Facesmode, select the face of port 1.
3. On the HFSSmenu, click Excitations > Assign > Port >Wave Port or, right-click in the

Modeler window and choose Assign Excitation > Port >Wave Port.

TheWave Port wizard appears.

4. In theWave Port: General dialog box, enter the nameWavePort1, keep the default Mode
settings, and click Next.

5. In theWave Port: Post Processing dialog box, accept the default settings and click Finish
to complete the wave port assignment for port 1.

WavePort1 is assigned to the waveguide and now appears as a subentry of Excitations in
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the Project Manager. SelectWavePort1 if it is not already displayed on the model.

Assign Wave Port 2
To assign wave port 2, you will use the same procedure you just followed to assign wave port 1,
but with the addition of an integration line.

When HFSS computes the excitation field pattern at a port, the direction of the field at ωt = 0 is
arbitrary; the field can always point in one of at least two directions.

For both wave port 2 and wave port 4, you must calibrate the port relative to some reference ori-
entation by defining an integration line in the up (that is, +Z) direction.

To assign wave port 2:

1. DeselectWavePort1 that you just assigned, if it is still selected.
2. In Select Facesmode, select the face of port 2.
3. Zoom in on the face of port 2.
4. On the HFSSmenu, click Excitations > Assign > Port >Wave Port.

TheWave Port wizard appears.

5. In theWave Port: General dialog box, enter the nameWavePort2.
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6. Click in row 1 of the Integration Line column and choose New Line from the drop-down
menu.

TheWave Port wizard disappears while you draw the vector.

7. Define the integration line:
a. Select the start point by clicking the center of the bottom edge of the face. Your

cursor will appear as a triangle when it is at this exact location, and it will snap to this
midpoint when clicked.

b. Select the end point by clicking the center of the top line on the face, which is dir-
ectly vertical to the start point you just selected. Again, your cursor will appear as a
triangle when it is at this exact location.

The endpoint defines the direction and length of the integration line.

TheWave Port wizard reappears, still at theWave Port: General step.

8. Click Next.
9. In theWave Port: Post Processing dialog box, accept the default settings and click Finish

to complete the wave port assignment for port 2.

WavePort1 is assigned to the waveguide and now appears as a subentry of Excitations in
the Project Manager. This wave port, with its integration line, is shown below:

Assign Wave Port 3
To assign wave port 3, use the same procedure you followed when you assigned wave port 1:

1. DeselectWavePort2 that you just assigned, if it is still selected.
2. In Select Facesmode, select the face of port 3.
3. On the HFSSmenu, click Excitations > Assign > Port >Wave Port.

TheWave Port wizard appears.
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4. In theWave Port: General dialog box, enter the nameWavePort3, keep the default Mode
settings, and click Next.

5. In theWave Port:Post Processing dialog box, accept the default settings and click Finish
to complete the wave port assignment for port 3.

WavePort3 is assigned to the waveguide and now appears as a subentry of Excitations in
the Project Manager.

Assign Wave Port 4
To assign wave port 4, you will use the same procedure you followed when you assigned wave
port 2:

1. DeselectWavePort3 that you just assigned, if it is still selected.
2. In Select Facesmode, select the face of port 4.
3. Zoom in on the face of port 4.
4. On the HFSSmenu, click Excitations > Assign > Port >Wave Port.

TheWave Port wizard appears.

5. In theWave Port: General dialog box, enter the nameWavePort4.
6. Click in the first row of the Integration Line column and select New Line from the drop-

down menu.

TheWave Port wizard disappears while you draw the vector.

7. Define the integration line:
a. Select the start point by clicking the center of the bottom line on the face. Your

cursor will appear as a triangle when it is at this exact location, and it will snap to this
midpoint when clicked.

b. Select the end point by clicking the center of the top line on the face, which is dir-
ectly vertical to the start point you just selected. Again, your cursor will appear as a
triangle when it is at this exact location.

The endpoint defines the direction and length of the integration line.

TheWave Port wizard reappears at theWave Port: General step.

8. Click Next.
9. In theWave Port: Post Processing dialog box, accept the default settings and click Finish

to complete the wave port assignment for port 4.

WavePort4, with its integration line, is assigned to the waveguide and now appears as a
subentry of Excitations in the Project Manager.
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Note:

To edit a wave port assignment:

1. In the Project Manager window, double-click the name of the wave port
assignment listed in the tree.

TheWave Port dialog box appears.

2. Click the appropriate tabs (General, Post Processing, Defaults) to edit any
port assignment information.

3. ClickOK to apply the assignment revisions.

Verify All Boundary and Excitation Assignments
Now that you have assigned all the necessary boundaries and excitations to a model, you
should review their specific locations on the model in the solver view.

When you verify boundaries and excitations in the solver view, you review the locations of the
boundaries and excitations as you have defined them for generating a solution (solving).

HFSS runs an initial mesh and determines the locations of the boundaries and excitations on the
model.

Then, you can select a boundary or excitation from the list in the Boundary Display (Solver
View) window to view its highlighted area in the model.

To check the solver’s view of boundaries and excitations:

1. Click HFSS > Boundary Display (Solver View) or right-click the HFSSDesignx entry in
the Project Manager and choose HFSS > Boundary Display (Solver View) from the
shortcut menu.

HFSS runs an initial mesh and determines the locations of the boundaries and excitations
on the model.

The Solver View of Boundaries window appears, listing all the boundaries and excit-
ations for the active model in the order in which they were assigned.
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2. Select a check box in the Visibility column that corresponds with the boundary or excit-
ation for which you want to review its location on the model.

The selected boundary or excitation appears in the model in the color it has been
assigned, as indicated in the Color column.

l Visible to Solver appears in the Solver Visibility column for each boundary that is
valid.

l Overridden appears in the Solver Visibility column for each boundary or excit-
ation that overwrites any existing boundary or excitation with which it overlaps.

3. Verify that the boundaries or excitations you assigned to the model are being displayed as
you intended for solving purposes.

4. If required, modify the parameters for those boundaries or excitations that are incorrect.
5. Click Close and then, from the Filemenu, click Save. Or, in any tab of the ribbon, click

Save.

Warning:

Be sure to save your models frequently. While Ansys Electronics Desktop does
periodically autosave models, the most convenient way to prevent loss of work in
the event of a problem is to save frequently.

You are now ready to set up the solution parameters for this waveguide combiner problem and
generate a solution.

Setting Up the Problem 5-21

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: 20 GHzWaveguide Combiner

6 - Set up and Generate a Solution
Now that you have defined and verified all the boundaries and excitations for the waveguide com-
biner problem, you are ready to set up and generate a solution.

Your goals for this chapter are to:

l Set up the solution parameters that will be used in calculating the solution.
l Validate the project setup.
l Generate the solution.
l View the solution data, such as convergence and matrix data information.

Time Aside from the solution time, it should take about 15 minutes for you to com-
plete the setup steps and to review the solution data.

Depending on your computing resources, the solution time may vary con-
siderably. This problem solved in approximately 10 minutes on a 1.4 GHz PC
with 1 gigabyte of RAM. On a 12-core, 3 GHz, Xeon-processor-based PC
with 64 GB of RAM, the solution took approximately 50 seconds to complete.

Specify Solution Options
Before you can generate a solution, you need to specify the solution parameters. This controls
how HFSS computes the requested solution.

Each solution setup includes the following information:

l General data about the solution’s generation.
l Adaptive mesh refinement parameters, if you want the mesh to be refined iteratively in
areas of highest error.

l Frequency sweep parameters, if you want to solve over a range of frequencies.

You can define more than one solution setup per design. However, you will define only one solu-
tion setup for this waveguide combiner problem.

Add a Solution Setup
Now, you will specify how HFSS will compute the solution by adding a solution setup to the wave-
guide combiner design.

To add a solution setup to the design:

1. Use one of the following three methods to add a solution setup to the design:
l From the HFSSmenu, click Analysis Setup > Add Solution Setup > Advanced.

l

From the Simulation ribbon tab, click Setup > Advanced.
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l From the Project Manager, right-click Analysis and choose Add Solution Setup >
Advanced.

The Driven Solution Setup dialog box appears.

The Driven Solution Setup dialog box is divided into the following tabs:

General Includes general solution settings.

Options Includes mesh options, adaptive options, and solution settings.

Advanced Includes advanced settings for initial mesh generation and adaptive ana-
lysis. Includes mesh generation options for model ports.

Defaults Enables you to save the current settings as the defaults for future solu-
tion setups or revert the current settings to HFSS’s standard settings.
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2. Under theGeneral tab:
a. Specify the following values:

Solution Fre-
quency

20 GHz
For every modal driven solution
setup, you must specify the fre-
quency at which to generate the
solution. For this waveguide com-
biner model, you will solve over a
range of frequencies, which will
require you to define a frequency
sweep in “Add a Discrete Fre-
quency Sweep”. If a frequency
sweep is solved, an adaptive ana-
lysis is performed only at the solu-
tion frequency.

Maximum Num-
ber of Passes

9
TheMaximum Number of Passes
value is the maximum number of
mesh refinement cycles that you
would like HFSS to perform. This
value is a stopping criterion for the
adaptive solution; if the maximum
number of passes has been com-
pleted, the adaptive analysis stops.
If the maximum number of passes
has not been completed, the adapt-
ive analysis will continue unless the
convergence criteria are reached.

Maximum Delta S
per Pass

0.001
The delta S is the change in the
magnitude of the S-parameters
between two consecutive passes.
The value you set forMaximum
Delta S Per Pass is a stopping cri-
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terion for the adaptive solution. If
the magnitude and phase of all S-
parameters change by an amount
less than this value from one iter-
ation to the next, the adaptive ana-
lysis stops. Otherwise, it continues
until the requested number of
passes is completed.

b. Accept all remaining default settings.
3. Accept all default settings on theOptions, Advanced, and Default tabs.
4. ClickOK.

The Edit Frequency Sweep dialog box appears. Keep this dialog box open. In the next
topic, you will define a discrete frequency sweep.

Add a Discrete Frequency Sweep
For models that include any type of assigned port excitation, upon completing the addition of an
advanced solution setup (previous topic), the Edit Frequency Sweep dialog box appears auto-
matically. Define a sweep to specify a range of frequencies over which results can be plotted,
such as S Parameters. HFSS performs the sweep after the adaptive solution.

For this waveguide combiner model, you will add a Discrete frequency sweep to the solution
setup. A discrete sweep generates results at specific frequency points over a specified fre-
quency range. You will specify a range of 19.5 GHz to 20.4 GHz, with a Step Size of 0.1 GHz.
The result will be ten solutions at increments of 0.1 GHz. By default, the field solution is only
saved for the final frequency point.

Be aware that HFSS uses the finite element mesh refined during an adaptive solution at the spe-
cified solution frequency. It uses this mesh without further refinement. Because the mesh for the
adaptive solution is optimized only for the specified solution frequency, it is possible that the
accuracy of the results could vary at frequencies significantly far away from the adaptive solution
frequency. If you wish to minimize the variance, you can opt to use the center of the frequency
range as the solution frequency. Then, after inspecting the results, run additional adaptive
passes with the solution frequency set to the critical frequencies.

Add a discrete frequency sweep to the solution setup:

1. The Add Frequency Sweep dialog box should already be displayed as a result of adding a
solution setup to a model with port excitations assigned.
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Note:

To manually access the Edit Frequency Sweep dialog box (for example to add a
second sweep or if you inadvertantly closed the dialog box prematurely), do the
following:

a. Select Setup1 under Analysis in the Project Manager.
b. Begin adding a frequency sweep using one of the following three methods:

l

From the Simulation ribbon tab, click Sweep.
l From the HFSSmenu, click Analysis Setup > Add Frequency
Sweep.

l Under Analysis > Setup1 in the Project Manager, right-click Setup1
and choose Add Frequency Sweep from the shortcut menu.

The Edit Frequency Sweep dialog box appears.

2. From the Sweep Type drop-down menu, select Discrete.
3. In the Frequency Sweeps table, select or enter these values to define the sweep:

Type Linear Step

Start 19.5GHz

Stop 20.4GHz

Step Size 0.1GHz

The table title should indicate [10 points defined] after Frequency Sweeps.

4. Clear Save Fields (All Frequencies), if it's currently selected.

When selected, the Save Fields option saves the field solution for each specified point.
The more steps you request, the longer it takes to complete the frequency sweep.
However, the S-parameters are always saved for every frequency point.

The dialog box should look like the following image:
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5. Click Preview to view each of the sweep values at the specified 0.1 GHz step size incre-
ment within the frequency range you specified.

6. ClickOK.

Sweep now appears as a subentry under Analysis > Setup1 in the Project Manager.

Validate the Project Setup
Before you run an analysis on the waveguide combiner model, it is important to first perform a
validation check on the project. HFSS runs a check on all the setup details of the active project to
verify that all the necessary steps have been completed and their parameters are reasonable.

To perform a validation check on the projectwg_combiner:

1. From the menu bar, click HFSS > Validation Check or, from the Simulation ribbon tab,

click Validate.

HFSS checks the project setup, and then the Validation Check window appears.

2. View the results shown in the Validation Check window.
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For this waveguide combiner project, a green check mark should appear next to each pro-
ject step in the list.

The following icons can appear next to an item:

Indicates the step is complete.

Indicates the step is incomplete.

Indicates the step may require your attention.

3. If the validation check indicates that a step in your waveguide combiner project is incom-
plete or incorrect, then return to the corresponding step in HFSS and carefully review its
setup.

4. Click Close.
5. Click File > Save to save any changes you may have made to your project.

Generating the Solution
Now that you have entered all the appropriate solution criteria and validated the project setup,
the waveguide combiner problem is ready to be solved.

When you set up the solution setup criteria for this model, you specified values for an adaptive
analysis (Maximum number of passes and Maximum delta S per pass). An adaptive analysis is a
solution process in which the mesh is refined iteratively in regions where the error is high, which
increases the solution’s accuracy.

The following is the general process the program carries out during an adaptive analysis:
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1. HFSS generates an initial mesh.
2. Using the initial mesh, HFSS computes the electromagnetic fields that exist inside the

structure when it is excited at the solution frequency. (If you are running a frequency
sweep, an adaptive solution is performed only at the specified solution frequency.)

3. Based on the current finite element solution, HFSS estimates the regions of the problem
domain where the exact solution has strong error. Tetrahedra in these regions are refined.

4. HFSS generates another solution using the refined mesh.
5. The software recomputes the error, and the iterative process (solve— error analysis —

refine) repeats until the convergence criteria are satisfied or the requested number of
adaptive passes is complete.

6. If a frequency sweep is being performed, as with this waveguide combiner problem, HFSS
then solves the problem at the other frequency points without further refining the mesh.

Analyze the Setup You Defined
Begin the solution process using any one of the following three methods:

l

From the Solution ribbon tab, click Analyze All. This command solves every solu-
tion setup in the design.

l Right-click Setup1 under Analysis in the Project Manager and choose Analyze. This com-
mand only solves the setup that you right-clicked.

l From the menu bar, click HFSS > Analyze All. This command solves every solution setup
in the design.

HFSS computes the 3D field solution inside the structure.

The Progress window displays the solution progress as it occurs:

Note:

The results that you obtain should be approximately the same as the ones given in this
section. However, there may be a slight variation between platforms and between dif-
ferent versions of the Ansys Electronics Desktop software.
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View the Solution Data
While the analysis is running, you can view a variety of profile, convergence, and matrix data
about the solution. The subsections that follow cover the available solution data.

View the Profile Data
While the solution proceeds, examine the computing resources, or profile data, used by HFSS
during the analysis.

The profile data is essentially a log of the tasks performed by HFSS during the solution. The log
indicates the length of time each task took and how much RAM/disk memory was required.

To view profile data for the solution:

l From the HFSSmenu, click Results > Solution Data or, right-click Setup1 in the Project
Manager and choose Profile from the shortcut menu.

The Solution Data dialog box appears with the Profile tab selected.
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Notice in the Simulation drop-down menu that Setup1 is selected as the solution setup.
By default, the most recently solved solution is selected.

For the Setup1 solution setup, you can view the following profile data:

Task Lists the software module that performed a task during
the solution process, and the type of task that was per-
formed.

For example, for the task mesh3d_adapt, Mesh3d is
the software module that adaptively refined the mesh.
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Real Time The amount of real time (clock time) required to perform
the task.

CPU Time The amount of CPU time required to perform the task.

Memory The amount of RAM/virtual memory required of your
machine to complete the task. This value includes the
memory required of all applications running at the time,
not just HFSS.

Information The number of tetrahedra in the mesh that were used
during the solution.

View the Convergence Data
To view convergence information for the solution:

l In the Solution Data window, click the Convergence tab.
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Based on the criteria you specified for Setup1, you can view the following convergence
data:

o Number of adaptive passes completed and remaining.

When the solution is complete, you can view the number of adaptive passes that
were performed. If the solution converged within the specified stopping criteria,
fewer passes than requested may have been performed.

o Number of tetrahedra in the mesh at each adaptive pass.
o Maximummagnitude of delta S between two passes.

For solutions with ports, as in Setup1, at any time during or after the solution pro-
cess, you can view the maximum change in the magnitude of the S-parameters
between two consecutive passes. This information is available after two or more
passes are completed.

The convergence data can be displayed in table format or on a rectangular (X - Y)
plot.

Note:

You can see that the solution is NOT CONVERGED. The Max. Mag. Delta S
value at the ninth pass is greater than the value that was specified in the setup
(0.001). You may decide that the level of accuracy achieved is acceptable. To
achieved a converged status, you could either relax the Max. Delta S require-
ment (to 0.004 or 0.005) or increase the Maximum Number of Passes (for
example, to 15).

For the purpose of this exercise, the current solution is sufficient.

View the Matrix Data
You can view matrices computed for the S-parameters during each adaptive and sweep solu-
tion.

To view the matrices:
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1. In the Solution Data window, click theMatrix Data tab.

2. In the Simulation drop-down menus, do the following:
a. Verify that Setup1 is selected as the solution setup you want to view.
b. Verify that LastAdaptive is selected as the solved pass you want to view.

3. Select S Matrix as the type of matrix data you want to view.
4. Click the Format subtab and ensure thatMagnitude/Phase (deg) is selected from the

drop-down menu as the format for displaying the matrix information.

You can display matrix data in the following formats:

Magnitude/Phase Displays the magnitude and phase of the matrix type.

Real/Imaginary Displays the real and imaginary parts of the matrix type.

dB/Phase Displays the magnitude in decibels and phase of the matrix
type.

Real Displays the real parts of the matrix type.

Imaginary Displays the imaginary parts of the matrix type.

Magnitude Displays the magnitude of the matrix type.

Phase Displays the phase of the matrix type.

dB Displays the magnitude in decibels of the matrix type.

5. Select the solved frequencies to display:
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l To display the matrix entries for all solved frequencies:
a. In the second Simulation drop-down menu, select Sweep.
b. Check Display All Frequencies.

l To show the matrix entries for one solved frequency:
a. Clear Display All Frequencies.
b. Select the solved frequency for which you want to view matrix entries.

For adaptive passes, only the solution frequency specified in the Solution Setup dialog
box is available. For frequency sweeps, the entire frequency range is available.

Consider the first S-matrix column (S:WavePort1:1) and third S-matrix column
(S:WavePort3:1) at 20 GHz. Notice that S12 and S32 (second row) as well as S14 and

S34 (fourth row) are all close to the value  .

Furthermore, the phases of S12 and S14 are 90-degrees apart. This angle is also true for
the phases of S32 and S34, but in the opposite way. These values indicates that if you
feed ports 2 and 4 with signals equal in magnitude but 90-degrees apart, they will add up
constructively in port 1 while canceling each other in port 3.

Also, S22, S24, S42, and S44 are all small in magnitude, indicating small return loss and
cross-talk to the wrong port.

6. Click Close when done viewing the Solution Data window.
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7 - Analyzing the Solution
Now, HFSS has generated a solution for the waveguide combiner problem. In general, you can
display and analyze the results of a project in many different ways. You can:

l Plot field overlays— representations of basic or derived field quantities — on surfaces or
objects.

l Create 2D or 3D rectangular or circular plots and data tables of S-parameters, basic and
derived field quantities, and, had the waveguide combiner model emitted radiation, radi-
ated field data.

l Plot the finite element mesh on surfaces or within 3D objects.
l Create animations of field quantities, the finite element mesh, and defined project vari-
ables.

l Scale an excitation’s magnitude and modify its phase.
l Delete solution data that you do not want to store.

For this waveguide combiner problem, you will:

l Create Modal S-parameter reports.
l Create a field overlay cloud plot of the magnitude of E.
l Create an animation of the mag-E cloud plot.

Time It should take you approximately 30 minutes to work through this
chapter.

Create an S-Parameters Report of S11, S12, S13, and S14
You are now ready to create the modal S-parameters reports.

1. To generate a 2D report of S11, S12, S13, S14, use one of the following three methods:
l From the HFSSmenu, click Results > Create Modal Solutions Data Report >
Rectangular Plot.

l

From the Results ribbon tab, choose 2D from the Modal Solution
Data Report drop-down menu.

l Right-click Results in the ProgramManager and click Create Modal Solutions
Data Report > Rectangular Plot.

The Report dialog box appears with the Trace tab initially selected.
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The Context selections are Setup1: Sweep in the Solution drop-down menu, and
Sweep in the Domain drop-down menu.

2. Select Primary Sweep: Freq, All and X: Default (Freq), if they are not already specified.
3. In the three option lists located below the Y text box, specify the following information to

plot along the Y-axis:

Category S Parameter

Quantity S(WavePort1,WavePort1); S(WavePort1,WavePort2);
S(WavePort1,WavePort3); S(WavePort1,WavePort4)

Function dB

Press and hold down Ctrl while clicking to select multiple items in a list.

The Primary Sweep option is Freq, which is also the default X: value to plot.

This option plots the sweep variables selected under the Families tab along the X-axis.

4. Click New Report and Close.

The function of the selected quantity is plotted against the plot domain on an xy graph.
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The report window XY Plot 1 appears, and S Parameter Plot 1 is now listed under Results
in the Project Manager. Each trace is also listed under S Parameter Plot 1 (four total).

Notice that the line charted for S11 indicates that this model has its lowest return loss at 20
GHz, if it were driven at port 1.

Create an S-Parameters Report of S12 and S14
To generate a 2D plot of S12 and S14:
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1. From the Results ribbon tab, choose 2D from the Modal Solution Data
Report drop-down menu.

The Report dialog box appears

The Context selections are Setup1: Sweep in the Solution drop-down menu, and
Sweep in the Domain drop-down menu.

2. Accept X: Freq and All, if they are not already selected.
3. In the three option lists located below the Y text box, specify the following information to

plot along the Y-axis:

Category S Parameter

Quantity S(WavePort1,WavePort2);S(WavePort1,WavePort4)

Function dB

4. Click New Report and Close.

The report window S Parameter Plot 2 appears and is listed under Results in the Project
Manager.
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Notice that between 19.9 GHz and 20 GHz, S12 and S14 are both approximately -3.1 dB.

Scale the Magnitude and Phase for the Ports
You will soon create a field overlay plot of the magnitude of E and examine the resulting E- field
pattern. But, before doing that, you must first scale the magnitude of the ports to represent equal
power input toWavePort2 andWavePort4, and zero at the other two ports. You must also
modify the phase angle forWavePort4. As a result, these settings will make the model behave
as the specific waveguide combiner that is described in this exercise.

To modify the magnitude and phase for the ports:
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1. From the menu bar, click HFSS > Fields > Edit Sources or right-click Field Overlays in
the Project Manager and click Edit Sources.

The Edit post process sources dialog box appears.

2. In theMagnitude text box forWavePort1:1 andWavePort3:1, enter 0.
3. In theMagnitude text box forWavePort2:1 andWavePort4:1, enter 1.

This magnitude is the factor by which the excitation value is scaled.WavePort2:1 and
WavePort4:1 are each to be fed the output of a separate solid state power amplifier
(SSPA).

Note:

Since this is a half-symmetry model of the actual waveguide combiner, the 1 W
port excitations are equivalent to 2 W at each input port of the full device that the
model represents.

Additionally, you may have noticed that, when you first accessed the Edit post
process sources dialog box, the default magnitude atWavePort1:1 was 0.5
(not 1). The reason is that you previously applied a symmetry boundary and,
accordingly, specified a port impedance multiplier of 2. Therefore, the program
decreased the source magnitude from the default value of 1 W to 0.5 W and, by
default, placed the excitation at the first port. The fact that you are applying a full
watt of power to each of the half-symmetry input ports is perfectly acceptable.
Just be aware that whatever excitation you apply is only half of the equivalent
magnitude going into the full part the model represents (due to the use of sym-
metry).

4. In the Phase text box forWavePort4:1, enter 90.

This value is the phase of the excitation entering the port.WavePort4 is the port to which
the output of an SSPA is fed 90 degrees out-of-phase relative to theWavePort2 excit-
ation.
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5. ClickOK.

The correct magnitude and phase are now assigned to all ports.

Create a Mag E Field Overlay
Now that you have scaled the magnitude and phase for each port, you are ready to create a field
overlay of the magnitude of E and examine the resulting E-field pattern.

1. In Select Facesmode (Edit > Selection Mode > Faces), click the top face of thewave-
guide object.

2. Use one of the following three methods to begin creating the mag E field overlay:
l On the HFSSmenu, click Fields > Plot Fields > E >Mag_E.
l Right-click Field Overlays in the Project Manager and click Plot Fields > E >Mag_
E.

l Right-click in theModeler window and click Plot Fields > E >Mag_E from the short-
cut menu.

The Create Field Plot dialog box appears.

3. SelectMag E from theQuantity list.

This command overlays the magnitude of the real part of the electric field |E|(x,y,z,t) as the
quantity to plot.
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4. Accept Setup1: LastAdaptive and 20 GHz as the Solution and Freq options, respect-
ively. In this case, these are the only available options.

The Freq drop-down menu includes a list of frequencies for which a field solution is avail-
able.

5. Select 0deg from the Phase drop-down menu.
6. Click Done.

TheMag_E1 field overlay appears on the geometry in theModeler window and is now lis-
ted under Field Overlays in the Project Manager.

The resultant E-field pattern shows that input from wave ports 2 and 4, with a 90-degree
out-of-phase separation, combine at port 1. The E-field at port 3 is approximately
0.0001 V/m, which is very close to zero. So, you can see that the waveguide combiner
behaved as expected with a 90-degree phase angle between the two inputs.

Create a Phase Animation of the Mag E Overlay
Next, you will create an animation of the E-field magnitude overlay to examine a frame-by-frame
animated behavior field.
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To create a phase animation of the Mag E plot:

1. Select theMag_E1 field overlay plot under Field Overlays > E Field in the Project Man-
ager.

2. Click HFSS > Fields > Animate.

The Select Animation dialog box appears.

3. Click New.

The Setup Animation dialog box appears.

4. Accept the default name Animation1 in the Name text box.
5. Optionally, type a description of the animation in the Description text box.
6. Under the Swept Variable tab, select Phase from the Swept variable list.
7. Accept the remaining default settings.
8. ClickOK.

The animation begins in theModeler window.

The Animation panel appears in the upper-left corner of the desktop, enabling you to stop,
restart, reverse, and control the speed of the frames.

Self-Study Challenge:
You may wish to experiment with different phase angles for the excitation atWavePort4. For
example, you could try an angle of 45 degrees, which should produce output at bothWavePort1
andWavePort3, with the latter having the weaker field. At a phase angle of zero, the output at
each port should be equal. Finally, at a phase angle of -90 degrees, all of the output should go to
WavePort3, with the field atWavePort1 being approximately zero.
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To adjust the phase angle atWavePort4, edit the port sources as described on the page, Scale
the Magnitude and Phase for the Ports. Simply adjust the angle specified in step 4 of that page.
You can keep the animation running and keep the Edit post process sources dialog box open
while applying different phase angles. When you click Apply, the animation will be updated
immediately and will continue to play.

Analyzing the Solution 7-10

Ansys Electromagnetics Suite 2024 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



Getting Started with HFSS: 20 GHzWaveguide Combiner

8 - Optionally, Restore Current View
Orientations

You have completed this getting started guide.

If you prefer to use the new view orientations implemented in version 2024 R1 of the Ansys Elec-
tronics Desktop application, clear the Use Legacy View Orientation option as follows:

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is cleared:

3. ClickOK.

The settings in the 3D UI Options dialog box are global. Your choice is retained for all future pro-
gram sessions, projects, and design types that use the 3D Modeler or that produce 3D plots of
results.
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You can now save and close this project.

Optionally, Restore Current View Orientations 8-2
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